通达信黑马资金指标公式

2020-04-11 14:47:24
分享到:

DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,'1',0);

VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);

VAR3:=EMA(VAR2,10);

VAR4:=LLV(LOW,33);

VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);

主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.6,0 ),COLOR000077;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.5,0 ),COLOR0000BB;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.9,0 ),COLOR0000DD;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;

拉升:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR005500;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.6,0),COLOR007700;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR009900;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.5,0),COLOR00BB00;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.9,0),COLOR00DD00;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00FF00;

{黑码}

A1:=EMA(C,12)-EMA(C,25);

A2:=EMA(A1,6);

获利回吐:=(A2>=0)*A2,COLORWHITE,LINETHICK1;

大黑码:=(A2<0)*A2,COLORD4FF7F,LINETHICK1;

坚绝做空:=(A1<0)*A1,COLORB00058,LINETHICK1;

买入持股:=(A1>=0)*A1,COLORRED,LINETHICK1;

STICKLINE(A2>=0,A2,0,5,0),COLORWHITE;

STICKLINE(A2<0,A2,0,5,0),COLORD4FF7F;

STICKLINE(A1<0,A1,0,5,0),COLORB00058;

STICKLINE(A1>=0,A1,0,5,0),COLORRED;

VAR8:=VOL>2*MA(VOL,30);

VAR9:="DMI.ADX"(12,6);

VARA:="DMI.ADXR"(12,6);

VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;

VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);

VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));

VARF:=TROUGHBARS(3,15,1)<4;

VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);

VAR11:=IF(VARF=1,50,0);

多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;0,COLORRED;

STICKLINE(FILTER(VARF=1,5) AND 多空<-10,80,0,8,0),COLORF00FF0;

STICKLINE(FILTER(VARF=1,5),60,0,4,0),COLORYELLOW;

{DRAWTEXT(FILTER(VARF=1,3),25,'黑码'),COLORRED ;

{STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW;

STICKLINE(多空>10,0,多空,0.95,0),COLORRED;};

周J1:MA("KDJ.J#WEEK"(9,3,3) ,5),COLORGREEN,LINETHICK2;

20,COLORMAGENTA,LINETHICK1;

80,COLORGREEN;

DRAWICON(CROSS(周J1,20),20,1);

DRAWTEXT(CROSS(周J1,20),15,'++抄'),COLORRED;

DRAWTEXT(CROSS(周J1,80),70,'=追'),COLORYELLOW;

{STICKLINE(周J1<0,周J1,0,5,0),COLORLIRED;

STICKLINE(CROSS(周J1,0),0,-50,3,0),COLORMAGENTA;

DRAWTEXT(CROSS(周J1,0),-35,'———底部'),COLORMAGENTA;}

{股旁网-股票指标公式 www.gupang.com}

{抓牛黑码

VAR1000:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR2000:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;

VAR3000:=SMA(SMA(VAR2000,3,1),3,1);

VAR4000:=EMA(VAR3000,5);

VAR5000:=LLV(LOW,26);

VAR6000:=HHV(HIGH,34);

VAR7000:=EMA((CLOSE-VAR5000)/(VAR6000-VAR5000)*4,4)*25;

{撞坷状?=IF(CROSS(VAR4000,10) AND VAR4000>10,50,0),STICK,COLORYELLOW,LINETHICK3;0,STICK,COLOR000000,LINETHICK3;

建仓区: IF((VAR7000<10),20,0), LINETHICK2,COLOR00CCFF ;

派发区: IF((VAR7000>90),80,100), LINETHICK2 ,COLORF00FF0;};

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。不构成任何投资建议,据此操作,风险自担。