通达信领航回归主图指标公式

2020-04-11 14:47:37
分享到:

N:=20;M:=32;P1:=80;P2:=100;

VAR1:=(C+H+O+L)/4;

卖出:XMA(VAR1,N)*(1+P1/1000),COLORFFFFFF,LINETHICK3;

买入:XMA(VAR1,M)*(1-P2/1000),COLOR0000FF,LINETHICK3;

DRAWBAND(卖出,RGB(200,50,55),卖出*1.03,RGB(0,100,50));

DRAWBAND(买入,RGB(0,55,0),买入*0.97,RGB(55,55,0));

幅度:100*(卖出-买入)/买入,NODRAW;

MA1:=MA(VAR1,3);

STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;

STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;

STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;

STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;

STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;

STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;

STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;

STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;

DRAWTEXT(CROSS(C,卖出),卖出*1.05,'卖出'),COLOR00FFFF;

机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0,LINETHICK2;

RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;

D2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;

J2:=3*K2-2*D2;

BB1:=EMA(J2,5);

BB2:=REF(BB1,1);

金叉:=CROSS(BB1,BB2);

DRAWTEXT(CROSS(C,买入) AND BB1>BB2 AND C>REF(O,2),买入*0.95,'买入'),COLOR0000FF;

DRAWICON(CROSS(C,买入) AND 金叉 AND 机会来临 ,LOW*0.96,26);

DRAWTEXT(CROSS(C,买入) AND 金叉 AND 机会来临,LOW*0.92,''),COLOR00FF00;

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。不构成任何投资建议,据此操作,风险自担。