通达信黄金指标公式

2020-04-11 14:47:43
来源:
分享到:

VAR1:=EMA(WINNER((LOW+HIGH)/2),10)*100;

VAR2:=EMA(WINNER(CLOSE),21)*100;

VAR3:=EMA(WINNER(CLOSE),34)*100;

VAR4:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;

X1: SMA(VAR4,5,1),COLOR00FF00 ,LINETHICK2 ;

X2: SMA(X1,3,1),,COLORYELLOW ,LINETHICK2 ;

X3: 3*X1-2*X2, ,COLORF00FF0 ,LINETHICK2 ;

VAR5:=EMA(CLOSE,26)-EMA(CLOSE,12);

VAR6:=EMA(VAR5,9)*8;

VAR7:=2*(VAR5-VAR6);

80,,COLORGREEN ,POINTDOT;

20, ,COLORGREEN,POINTDOT;

VAR8:=CLOSE*50/100;

VAR9:=MA(VAR8,30)*0.83;

VARA:=MA(VAR8/VAR9,3);

IF(VARA<103/100,20,0),LINETHICK2,COLOR23ACFF;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),4,1)/

SMA(ABS(CLOSE-LC),4,1)*100;

顶部雷达:CROSS(80,RSI)*100,,LINETHICK2, COLORF0F000;

{DRAWTEXT(CROSS(80,RSI) , 100,1)COLORGREEN;}

VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;

VARC:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;

VARD:=BARSCOUNT(CLOSE);

底部雷达:(VARB< 20 AND VARC< 25 AND VARD> 50)*100, ,LINETHICK2 ,COLORYELLOW;

{DRAWTEXT(CROSS(100,底部雷达) ,100,2), , LINETHICK1 COLORMAGENTA;}VAR11:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE < REF(CLOSE,1),0-VOL,0)),0);

VAR12:=SUMBARS(VOL,CAPITAL);

VAR13:=IF(CLOSE>LLV(CLOSE,VAR12),1,-1)*IF(VAR11>LLV(VAR11,VAR12),1,-1);

VAR14:=IF(VAR13=-1,1,0);

VAR15:=COUNT(VAR14=1,8)>2;

VAR16:=SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100;

VAR17:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/VAR16);

VAR18:=(CLOSE-VAR17)/VAR17*100<-15;

VAR19:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.05;

RSW: VAR18 AND VAR19 AND VAR15,COLORRED;

DRAWTEXT(RSW>0 AND REF(RSW,1)=0,50,3),COLORRED;

VAR88:=MA(CLOSE,27);

VAR98:=(CLOSE-VAR88)/VAR88*100;

VARA8:=MA(VAR98,2);

VARB8:=BARSLAST(CROSS(-10,VARA8)=1);

VARC8:=BARSLAST(CROSS(VARA8,10)=1);

VARD8:=VARA8<-10 AND VARB8>3;

VARE8:=VARA8>10 AND VARC8>3;

黄金坑: IF(VARD8,VARA8,0),LINESTICK ,LINETHICK2, COLORYELLOW;

A1:=REF(CLOSE,2);

A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;

波段介入点:IF(A2<19,19,0);

LC5:=REF(CLOSE,1);RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT(CROSS(RSI,11),LOW,4),COLORRED;VAR78:=EMA(AMOUNT/VOL/100,3); BB10:=100*(C-COST(10))/COST(10);

BB1:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;

BB2:=SMA(BB1,4,1);

BB3:=SMA(BB2,2,1);

BB4:=VOL/CAPITAL*34;

BB5:=REF(BB4,1);

主力建仓提醒: IF(BB3<8.5 AND BB2<11,-10,0),COLORRED;

VARO2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;

VARO3:=SMA(SMA(VARO2,3,1),3,1);

VARO4:=EMA(VARO3,5);

VARO5:=LLV(LOW,26);

VARO6:=HHV(HIGH,34);

VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;

STICKLINE(CROSS(VARO4,10) AND VARO4>10,25,0,8,0),COLORYELLOW;

建仓区: IF((VARO7<6),80,100),LINETHICK2, COLOR00CCFF;

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。