通达信天神捉妖选股指标公式

2020-04-11 14:47:44
来源:
分享到:

粘合度N:=360;

N1:=5;

N2:=14;

N3:=34;

N4:=55;

N5:=99;

N6:=144;

距离:=22;

N0:=3;

SHORT:=12;

LONG:=29;

MID:=9;

{机构增仓}

JA1:=(VOL/C)/2;

A2YT:=SUM(IF(JA1>100 AND REF(CLOSE,1)>REF(CLOSE,2),JA1,0),0);

A3Y:=SUM(IF(JA1>100 AND REF(CLOSE,1)<REF(CLOSE,2),JA1,0),0);

A4Y:=SUM(IF(JA1<100 AND REF(CLOSE,1)>REF(CLOSE,2),JA1,0),0);

A5Y:=SUM(IF(JA1<100 AND REF(CLOSE,1)<REF(CLOSE,2),JA1,0),0);

A6Y:=A2YT+A3Y+A4Y+A5Y;

机买:=(A2YT/A6Y)*100;

机卖:=(A3Y/A6Y)*100;

主力差:=机买-机卖;

机构加仓:=(主力差>REF(主力差,1)+1.2) AND 机买>机卖;

XXBB:= EMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*4,5)*100;

追拉升:=REF(XXBB,1)>50 AND XXBB-REF(XXBB,1)>40;

机构追买:=机构加仓 AND 追拉升;

{何氏妖股}

月DIF:="MACD.DIF#MONTH";

月DEA:="MACD.DEA#MONTH";

周DIF:="MACD.DIF#WEEK";

周DEA:="MACD.DEA#WEEK";

日DIF:="MACD.DIF";

日DEA:="MACD.DEA";

日金叉:=CROSS(日DIF,日DEA);

周金叉:=CROSS(周DIF,周DEA);

月金叉:=CROSS(月DIF,月DEA);

WIW:=((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR (周DIF>周DEA AND 月DIF>月DEA AND 日金叉)OR (日DIF>日DEA AND 月DIF>月DEA AND 周金叉)OR (日金叉 AND 周金叉 AND 月金叉)OR (日DIF>日DEA AND 周DIF>周DEA AND 月DIF>月DEA));

月K:="KDJ.K#MONTH";

月D:="KDJ.D#MONTH";

周K:="KDJ.K#WEEK";

周D:="KDJ.D#WEEK";

日K:="KD.K";

日D:="KD.D";

日金叉1:=IF(CROSS(日K,日D),15,0);

周金叉1:=IF(CROSS(周K,周D),25,0);

月金叉1:=IF(CROSS(月K,月D),35,0);

日周月:=IF(日金叉1=15 AND 周金叉1=25 AND 月金叉1=35,1,0);

日周月赚:=日周月=1;

日周:=IF(日金叉1=15 AND 周金叉1=25,2,0);

日周赚:=日周=2;

周月:=IF(周金叉1=25 OR 月金叉1=35,4,0);

日月:=IF(日金叉1=15 AND 月金叉1=35,5,0);

日月赚:=日月=4;

周月赚:=周月=3;

S1:=日K>日D;S2:=周K>周D;S3:=月K>月D;

WHW:=((S1 AND S2 AND 周金叉1 AND 日金叉1)OR(S1 AND S2 AND 周金叉1 AND 月金叉1)OR(S1 AND S3 AND 周金叉1 AND 月金叉1)OR(日金叉1 AND 周金叉1 AND 月金叉1)OR(S2 AND S3 AND 周金叉1 AND 月金叉1)OR(日金叉1 AND 周金叉1 AND S2 AND S3)OR(S1 AND S3 AND S2)OR(日月赚 AND 日周月赚 AND 周月赚)OR(日月赚 AND 日周赚 AND 日周月赚)OR(日周赚 AND 日周月赚 AND 周月赚)OR(日月赚 AND 日周赚 AND 周月赚));

涨停1:=(H/REF(C,1)>1.099 AND C=H) OR (H/L>1.11 AND C/L>1.06);

Y1Y:=COUNT(WIW,18)>0 OR COUNT(WIW,48)>0 OR WIW;

Y2Y:=COUNT(WHW,18)>0 OR COUNT(WHW,48)>0 OR WHW;

Y3Y:=COUNT(机构加仓 OR 机构追买,18)>0 OR COUNT(机构加仓 OR 机构追买,48)>0 OR (机构加仓 OR 机构追买);

A1T:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));

A2T:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1T);

金线王:=C>=EMA(A2T,144);

JXWS:= C>金线王#MIN30 OR C>金线王#MIN60 OR C>金线王;

天神捉妖:Y1Y AND Y2Y AND Y3Y AND JXWS;

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。